The Activity Must Be Exported Or Contain An Intent-Filter, Activity Must Be Exported

Error running Dashboard: The activity must be exported or contain an intent-filterHow can I solve this error?

*

*

I changed the Select Run/Debug Configuration from my MainActivity to App and it started working. Select App configuration snapshot:

*

*

*

Double check your manifest, your first activity should have tag

inside of activity tag.

You are watching: The activity must be exported or contain an intent-filter

If that doesn”t work, look for target build, which located in the left of run button (green-colored play button), it should be targeting “app” folder, not a particular activity. if it doesn”t targeting “app”, just click it and choose “app” from drop down list.

Hope it helps!

*

First check a Launch Activity is set in your “manifest.xml” file has:

If this is set correctly, next check your run/debug configuration is set to “App”,

*

If the “App” configuration is missing – you will need to add it by first selecting “Edit Confurations”

*

If you do not have a “App” configuration you will need to create one, else select you “App” configuration and skip the creating steps. Also if your configuration is corrupt you may need to delete it but first backup your project. To delete a corrupt configuration, select it by expanding the “Android App” node and chose the “-” button.

*

To create a new configuration, select the “+” button and select “Android App”

*

If you have just created the configuration you will be presented with the following default name value of “Unnamed” and module will have the value “” then hit “Apply” and “OK”.

*

Set this the name to “App” and select “app” as the module.

See more: Njpw Best Of The Super Juniors 2017 Best Of The Super Juniors Lineup

*

Next select “App” as the run configuration and Run.

*

Thats it!

Share
Improve this answer
Follow
answered Aug 20 “18 at 1:05
Sagar PatelSagar Patel
88177 silver badges1313 bronze badges
1
Add a comment |
11
just add intent-filter Tag inside your activity

for example ::

Share
Improve this answer
Follow
answered Nov 29 “16 at 21:13
Houssem CherifHoussem Cherif
1601010 bronze badges
1
Add a comment |
8
Just Select App from dropdown menu with Run(green play icon). it will run the whole the App not the specific Activity. if it doesn”t help try to use in that activity in ManiFest.xml file. thankyou

Share
Improve this answer
Follow
answered Feb 27 “17 at 15:17
Raheel KhanRaheel Khan
39477 silver badges1111 bronze badges
1
Add a comment |
8
If you”re trying to launch a specific activity instead of running the launcher one.When you select that activity. the android studio might through this error,Either you need to make it launcher activity, just like answered by few others.or you need to add android:exported=”true” inside your activity tag inside manifest. It allows any external tool to run your specific activity directly without making it a launcher activity

Share
Improve this answer
Follow
answered Apr 13 “19 at 7:38
GaneshGanesh
35855 silver badges1515 bronze badges
Add a comment |
5
In manifest.xml, select activity which u wanna start e set this informations:

Share
Improve this answer
Follow
answered Apr 9 “17 at 0:43
Diego VenâncioDiego Venâncio
4,50622 gold badges3535 silver badges5858 bronze badges
Add a comment |
2
it”s because you are trying to launch your app from an activity that is not launcher activity. try run it from launcher activity or change your current activity category to launcher in android Manifest.

Share
Improve this answer
Follow
edited Feb 3 “18 at 7:27
answered Sep 21 “17 at 4:59
Ehsan.sarsharEhsan.sarshar
11911 gold badge11 silver badge66 bronze badges
Add a comment |
2
Sometimes if you change the starting activity you have to click edit in the run dropdown play button and in app change the Launch Options Activity to the one you have set the LAUNCHER intent filter in the manifest.

See more: Which Reason Best Explains Why American Cities Grew In The Late 1800S?

Share
Improve this answer
Follow
answered Jan 16 “19 at 18:25
Tony MerrittTony Merritt
1,0871111 silver badges3232 bronze badges
Add a comment |
1
Check your manifest,Open the file with .xml extension and then all your activities are listed your first activity should have this code enclosed in its tags

or there is another way u can choose from configuration which is drop down list on the left side of run button choose from App from it Hope it will help!!

Share
Improve this answer
Follow
answered Aug 2 “17 at 20:10
Usama TahirUsama Tahir
64988 silver badges1414 bronze badges
Add a comment |
Highly active question. Earn 10 reputation (not counting the association bonus) in order to answer this question. The reputation requirement helps protect this question from spam and non-answer activity.

Not the answer you're looking for? Browse other questions tagged java android android-activity or ask your own question.

The Overflow Blog
Upcoming Events
Featured on Meta
Linked
0
The activity must be exported or contain an intent-filter Android studio
0
Activity doesn't launch in Android Studio
0
Manifest merger failed with multiple errors in the Project
1
Using Multiple intents with different activities and final email intent
0
Android studio 'The activity must be exported or contain an intent-filter'
0
The activity must be exported or contain an intent-filter – even though there's an intent filter
0
Start-up activity cannot be changed
1
The activity must be exported or contain an intent-filter error
Related
1355
Strange OutOfMemory issue while loading an image to a Bitmap object
1145
Fling gesture detection on grid layout
1217
Is quitting an application frowned upon?
1097
Download a file with Android, and showing the progress in a ProgressDialog
952
onActivityResult is not being called in Fragment
2580
How can I fix 'android.os.NetworkOnMainThreadException'?
1171
Can't execute jar- file: “no main manifest attribute”
1121
You need to use a Theme.AppCompat theme (or descendant) with this activity
1174
How do I “select Android SDK” in Android Studio?
798
All com.android.support libraries must use the exact same version specification
Hot Network Questions more hot questions
Question feed
Subscribe to RSS
Question feed To subscribe to this RSS feed, copy and paste this URL into your RSS reader.

lang-java
Stack Overflow
Products
Company
Stack Exchange Network
site design / logo © 2021 Stack Exchange Inc; user contributions licensed under cc by-sa. rev2021.10.20.40515

Stack Overflow works best with JavaScript enabled

*

Your privacy

By clicking “Accept all cookies”, you agree Stack Exchange can store cookies on your device and disclose information in accordance with our Cookie Policy.

Published

Leave a comment

Your email address will not be published. Required fields are marked *